obs-ndiインストール時に「unmet dependencies」が出る場合の対処法

obs-ndiの.debパッケージをインストール時に、下記のようなエラーが発生する場合があります。

Unable to install obs-ndi:
The following packages have unmet dependencies:
Package created with checkinstall 1.6.2

この問題は、obs-ndiとobs-studioを削除し、PPAバージョンのobs-studioをインストールすることで解消可能です。

PPAバージョンのインストール方法は、OBSProject.comのwikiで解説されています。

Wiki - Install Instructions | OBS
If you want to develop for OBS, please visit our [Discord](https://obsproject.com/discord) and get to know the devs or have questions answered! Also, if there is something in this …

以下は、Ubuntu/Mintへのインストール手順の適当な翻訳です。責任は負いません。

OBS StudioはChrome OS上では完全には動作せず、スクリーンキャプチャやウィンドウキャプチャなどの機能は動作しませんのでご注意ください。

  • フルスクリーンプロジェクターなど、OBSの特定機能で潜在的なパフォーマンス問題を回避するために、xserver-xorgバージョン1.18.4以降が推奨されます。

  • FFmpegが必要です。FFmpeg がインストールされていない場合(確信が持てない場合は、おそらく持っていないでしょう)、以下のコマンドで取得できます:

    sudo apt install ffmpeg
    
  • 仮想カメラをサポートするには、v4l2loopback-dkmsをインストールする必要があります。以下のコマンドでインストールできます:

sudo apt install v4l2loopback-dkms
  • Ubuntuソフトウェアセンターでmultiverseのリポジトリを有効にしたことを確認してください(注意:Ubuntuの新バージョンでは、リポジトリを追加すると自動的にaptアップデートが行われます)。その後、以下のコマンドでOBSをインストールします。

    sudo add-apt-repository ppa:obsproject/obs-studio
    sudo apt update
    sudo apt install obs-studio